Next Gen Security Testing Services

Apache Commons Configuration vulnerability RCE CVE-2022-33980

Apache Commons Configuration Vulnerability Details

Apache Commons Configuration performs variable interpolation, allowing properties to be dynamically evaluated and expanded. The standard format for interpolation is “${prefix:name}”, where “prefix” is used to locate an instance of org.apache.commons.configuration2.interpol.Lookup that performs the interpolation. Starting with version 2.4 and continuing through 2.7, the set of default Lookup instances included interpolators that could result in arbitrary code execution or contact with remote servers. These lookups are: – “script” – execute expressions using the JVM script execution engine (javax.script) – “dns” – resolve dns records – “url” – load values from urls, including from remote servers Applications using the interpolation defaults in the affected versions may be vulnerable to remote code execution or unintentional contact with remote servers if untrusted configuration values are used. Users are recommended to upgrade to Apache Commons Configuration 2.8.0, which disables the problematic interpolators by default. (CVE-2022-33980)

The Commons Configuration software library provides a generic configuration interface which enables a Java application to read configuration data from a variety of sources. Commons Configuration provides typed access to single, and multi-valued configuration parameters. Apache Commons Configuration performs variable interpolation, allowing properties to be dynamically evaluated and expanded. 

These lookups are:

  • “script” – execute expressions using the JVM script execution engine (javax.script)
  • “dns” – resolve dns records
  • “url” – load values from urls, including from remote servers

Affected version Apache

Commons Configuration < 2.8

Impact

Applications using the interpolation defaults in the affected versions may be vulnerable to remote code execution or unintentional contact with remote servers if untrusted configuration values are used.

Solution

In this regard, we recommend that users upgrade Apache CouchDB to version 2.8 in time to fix CVE-2022-33980.