CVE-2022-3786 and CVE-2022-3602: OpenSSL Patches Two High Severity Vulnerabilities

CVE-2022-3786 and CVE-2022-3602: OpenSSL Patches Two High Severity Vulnerabilities

OpenSSL has patched two vulnerabilities, pivoting from its earlier announcement, in version 3.0.7.


On October 25, OpenSSL announced that a forthcoming release of OpenSSL version 3.0.7 would contain a patch for a critical vulnerability. That announcement preceded the release by one week, leaving ample time for speculation regarding the nature and impact of the vulnerability.

On November 1, OpenSSL released version 3.0.7 and updated its announcement, stating that investigations in the intervening week revealed a vulnerability that originally appeared to be critical was only high severity. The release also included a second high severity flaw. With the release of 3.0.7, OpenSSL patched CVE-2022-3786 and CVE-2022-3602, two buffer overflows that could result in denial of service. They affect OpenSSL versions 3.0 and later, which have only been available since September 2021 at the earliest.

At the time of initial publication, there are no public proofs-of-concept available or reports of exploitation in the wild for either of these flaws.

While the likelihood of widespread exploitation is low, organizations should prioritize patching affected applications and services as updates become available.


CVE-2022-3786 and CVE-2022-3602 are buffer overrun vulnerabilities in the name constraint checking function of the X.509 certificate verification in OpenSSL. Both flaws are rated as HIGH severity. Exploitation occurs when a certificate contains a specially crafted punycode-encoded email address designed to trigger the buffer overrun. Successful exploitation could lead to a denial of service (DOS) condition.

CVE-2022-3602 was originally considered critical due to the possibility of remote code execution (RCE). However, during its prenotification process, OpenSSL determined that the potential for RCE was mitigated by the fact that modern platforms contain stack overflow protections and that in some Linux distributions, both RCE and DOS were not feasible. Broadly speaking, the risk for RCE is low, though not zero, which is why the severity of the vulnerability was changed from critical to high.

To exploit both flaws, an attacker would need to convince a certificate authority to sign a malicious certificate or “for the application to continue with the certificate verification despite failure to construct a path to a trusted issuer.”

OpenSSL says that these flaws were introduced in OpenSSL 3.0.0 following the addition of its punycode decoding functionality, which is used for “processing email address name constraints in X.509 certificates.” Therefore, this flaw only impacts OpenSSL 3.0.0 through OpenSSL 3.0.6.


OpenSSL version 3.0.7 has been released to address these vulnerabilities. Downloads for the new release can be found here.

Identifying affected systems

A list of Tenable plugins to identify thesevulnerabilities will appear here as they’re released. This link uses a search filter to ensure that all matching plugin coverage will appear as it is released. Additionally, the plugins in this list can be used for generic OpenSSL version detection.

Get more information

OpenSSL Security Advisory
OpenSSL Team Blog – CVE-2022-3786 and CVE-2022-3602: X.509 Email Address Buffer Overflows
OpenSSL Release Notes

Join Tenable’s Security Response Team on the Tenable Community.

Learn more about Tenable, the first Cyber Exposure platform for holistic management of your modern attack surface.

Get a free 30-day trial of Vulnerability Management.


​Cyber Exposure Alerts Read More 

More To Explore

Red Hat Security Advisory 2023-3304-01

Red Hat Security Advisory 2023-3304-01 – Red Hat OpenShift Container Platform is Red Hat’s cloud computing Kubernetes application platform solution designed for on-premise or private

We can help improve your Business

Ensure your Organization Assets are well  protected in front of the Cyber Attacks

Delivery Workflow

Register for Free and get your test done withn 24 to 48 hours

See Workflow

Sample Report

Here is a sample report of a Security Testing Engagement

See Sample Report PDF

Work Request

Order your security test and Get Your Report

Get Your Test Report
Generated by Feedzy

1. Client Onboarding

Access to all of Cyber Legion's services is provided through the Web Secure Client Portal. To create a Free account, you can sign up through the portal, or contact the Cyber Legion team and they will set up an account for you.

2. NDA , Agreements & Digital Signature

The integration of Digital Signature in our Web Client Portal allows us to legally sign all necessary documents and agreements, enabling us to carry out security assessments on targeted systems.

3. Submit Work Request

Our pricing structure is adaptable to meet the needs of all clients. By filling out the Work Request Form, you can select from pre-existing services or request a personalized proposal.

The Cyber Legion team will acknowledge your order, set up a project in your account, and proceed with the testing and delivery.

4. Security Testing & Report

We meet agreed upon SLAs and follow security testing framework checklists. Based on our commitment, our team of engineers will utilize all of our tools, automation, and testing capabilities to achieve the objectives.

Within the agreed upon timeframe, you will receive a report on the security test that was conducted, including the results, recommendations, and references for addressing any identified issues.

5. Retesting & Validation of Remediation

We not only identify potential threats, risks, and vulnerabilities, but also provide detailed recommendations for resolution. To ensure complete remediation, we offer complimentary retesting and a range of ongoing security testing options for continued vulnerability detection and verification.