CVE-2023-22518: Critical Atlassian Confluence Data Center and Server Improper Authorization Vulnerability

Secure your products with top-tier expert knowledge and advanced Penetration Testing (CREST Approved)

Let's collaborate to build and maintain secure, trustworthy products

We transform threats into trust by integrating advanced tech and expertise in product security. Our approach encompasses Security by Design, rigorous security assurance and penetration testing, and compliance through expert documentation, from design to post-market. We offer CREST-approved pen testing in EMEA, upholding top security standards.

CREST Approved in EMEA

Atlassian warns of public vulnerability details for a critical flaw in Confluence Data Center and Server, as its CISO urges organizations to apply patches immediately


On October 31, Atlassian published an advisory for a critical vulnerability in Confluence Data Center and Server, a popular web-based wiki.

CVEDescriptionCVSSv3VPR*CVE-2023-22518Atlassian Confluence Data Center and Server Improper Authorization Vulnerability9.16.7

*Please note: Tenable’s Vulnerability Priority Rating (VPR) scores are calculated nightly. This blog post was published on November 3 and reflects VPR at that time.

According to its advisory, Atlassian says that all versions of Confluence Data Center and Confluence Server are affected by this vulnerability.


CVE-2023-22518 is an improper authorization vulnerability in the setup-restore endpoints of Atlassian Confluence Data Center and Server. An attacker could exploit this vulnerability by sending specially crafted requests with the required parameters to the vulnerable endpoints on a Confluence Data Center or Server instance. According to Atlassian’s advisory, successful exploitation of this flaw could result in “significant data loss.” An FAQ blog post from Atlassian notes that successful exploitation would reset an instance’s content, thereby requiring a restore from a backup as the only way to recover the lost data.

Atlassian CISO issues warning to customers

In an unprecedented move, Atlassian’s advisory includes a statement from its chief information security officer (CISO), Bala Sathiamurthy, who specifically called out that “significant data loss” could occur if exploited by “an unauthenticated attacker.” In his note, Sathiamurthy underscored that customers “must take immediate action to protect their instances.”

Publicly available vulnerability details increases risk of potential exploitation

On November 2, Atlassian updated its advisory with an observation that “publicly posted critical information about the vulnerability” had become available, which “increases risk of exploitation.” The information observed includes write-ups about the vulnerability by security researchers, which could be used to develop a working proof-of-concept exploit. The advisory also points out that publicly accessible instances are at the most risk.

Second critical flaw in Atlassian Confluence in the last month

This is the second critical vulnerability disclosed in Atlassian Confluence Data Center and Server in the last month. In October, Atlassian patched CVE-2023-22515, another critical flaw in Confluence Data Center and Server, that was exploited in the wild as a zero-day.

Because Confluence Data Center and Server is often an internet-facing asset, it has become a popular target for cybercriminals over the last few years. As of November 3, no in-the-wild exploitation has been observed for CVE-2023-22518. However, with vulnerability details now public, we anticipate in-the-wild attacks to begin soon.

Proof of concept

On November 2, write-ups about and exploitationdemonstrations of CVE-2023-22518 were published on social media and blog posts. The information contained within these write-ups provide enough information for an attacker to potentially develop their own working proof-of-concept exploit.

analysis for CVE-2023-22518
confluence unauth RCE

— Henry Chen (@chybeta) November 2, 2023



Atlassian have released the following fixed versions of Confluence Data Center and Server to address this vulnerability:

Affected VersionsFixed Version7.19.15 and below7.19.16 and above8.3.3 and below8.3.4 and above8.4.3 and below8.4.4 and above8.5.2 and below8.5.3 and above8.6.0 and below8.6.1 and above

If patching is not feasible at this time, Atlassian recommends backing up the Confluence instance and applying the following temporary mitigations until patches can be applied:

Mitigation #1: Remove instance from the internet until patching is feasible – By leaving a vulnerable Confluence instance publicly accessible, they are vulnerable to exploitation, so it is advised that customers restrict external network access until patches can be appliedMitigation #2: Block access to vulnerable endpoints on Confluence instances – Atlassian highlights three specific endpoints that are known attack vectors: – /json/setup-restore.action – /json/setup-restore-local.action – /json/setup-restore-progress.action – Customers are advised to modify the specific Confluence configuration files and adding in a security constraint to block access to these endpoints

For more information about the specific temporary mitigations, please refer to the relevant section in the Atlassian advisory.

Identifying affected systems

A list of Tenable plugins to identify can be located on the individual CVE page for CVE-2023-22518. This link will display all available plugins for this vulnerability, including upcoming plugins in our Plugins Pipeline.

Get more information

Atlassian Advisory for CVE-2023-22518CONFSERVER-93142: Atlassian JIRA Ticket for CVE-2023-22518Atlassian FAQ for CVE-2023-22518

Join Tenable’s Security Response Team on the Tenable Community.

Learn more about Tenable One, the Exposure Management Platform for the modern attack surface.

   Cyber Exposure Alerts 


More To Explore